installare amule 2.3.1

eccomi qui, dopo tempo ritorno a scrivere sul mio blog…

questa volta parliamo di amule 2.3.1 installato su mint12

e su questa versione di mint vorrei dire quattro parole…

come sapete mint si basa su ubuntu, secondo me la particolarità che lo distingue da ubuntu e quella di non rilasciare numerose ver. ogni 3 mese
lasciandomi con programmi non più funzionanti…

ma di recente ho avuto una spiacevole notizia dopo l’aggiornamento di mint, cioè quella di dover disintallare amule..
dò il mio consenso pensando, tanto alla fine lo installo nuovamente senza problemi…bhè ho pensato..

e qui inizia la mia piccola “avventura”…

inizio dando al terminale il comando apt-get install amule..
ecco che comincia a richiedere delle dipendenza che non potevo soddisfare…ormai con mai avevo dimenticato queste problematiche..
ma ecco che come un bumerang ritornano..allora dopo essermi ricavato del tempo ho deciso di risolvere il problema..
la libreria che mi richiedeva era libcrypto++8, ovviamente impossibile da soddisfare perchè nei reposity era scoparsa sostituita dalla ver. 9

quindi ho deciso di installare la nuova ver. di amule e cioè la 2.3.1, come se nei miei repositery c’è solo la vecchia ver.

prima di procedere ho fatto pulizia di tutto ciò che riguarda amule, quindi le opzioni sono due o date apt-get purge/autoremove
oppure andate in gestore applicazioni cercate amule e togliete tutto quello che trovato installato

allora googlando ho trovato la nuova ver. in formato .deb(grazie debian per averci permesso di installare i programmi con un semplice clic)

però ovviamente amule richiede le sue dipendenze che sono

amule-common – libupnp6 – libwxbase – libwxgtk2 che a sua volta richiede libtiff4 – libjbig

quindi scaricando e installando in ordine tutte queste librerie sono riuscito a far girare tranquillamente amule sul mio computer..
però per installare libupnp6 sono stato costretto ad eliminare vlc, perchè ha una dipendenza con libupnp3 che con l’installazione della ver. 6 ovviamente la ver. 3 viene eliminata..

dopo aver installato tutto ho provato ad installare vlc dal repositery ma amule poi non funziona più..
quindi adesso sto provando ad installare l’ultima versione di vlc…

dopo questa piccola perdita di tempo spero che mint non si riproponga con questi aggiornamenti,
non voglio cominciare ad incrociare le dita ad ogni aggiornamento come facevo con ubuntu..

tutti i pacchetti li potete trovare qui, li ho uppati su rapidshare per evitare a voi di cercarli uno ad uno sul sito di debian..

ma se volete potete iniziare a scaricare amule da qui e poi dal sito stesso scaricare le librerie che vi servono

Questa voce è stata pubblicata in Uncategorized e contrassegnata con , , , , , , . Contrassegna il permalink.

Lascia un commento

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...